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Module Objectives:
· Become proficient in the RDz Java Perspective
· Be able to extract data from a DB2 table using Java

Creating a Java program to access DB2 9.1 on System z
Create a Java Application
This example creates a Java application that runs against DB2 9.1 on the host (z10).  One must create the DB2 9.1 table before this project will run.  

Open RDz and ensure you have a z/OS connection (Remote System).  To create a Java Project, you will need to open the Java Perspective.

To switch to the Java Perspective: 

1. Perspectives that have been opened in RDz are kept usually as expandable tabs in the upper right corner of your Remote System perspective.  If you have not previously opened the Java perspective, click Window => Perspective => other. A dialog box displays. 

[image: ][image: ]


2. Select Java and click OK. RDz automatically arranges the windows, views, and editors for Java development tasks.   Package Explorer (only Packa displayed) is shown below.


[image: ]


To create a Java project: 

1. Click File => New => Project => Java Project

[image: ]



[image: ]2.    Click the Next button and name the new project –JDBCJava for this example.
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Accept the default values and click the Finish button (not shown).  The result is shown below.

[image: ]

To create a Java package within the project: 

1. Right-click the project (JDBC Java in this case) in the Package Explorer window and select New => Package

[image: ]

3. Enter a name for the new package such as com.acctid (com.douglas in this case) and click the Finish button (not shown) 

[image: ]

[image: ]The package is created as shown








To create a Java class: 

1. Right-click the project (JDBCJava) in the Package Explorer window and select New => Class. 

3. Use the Browse button to select your package, for example com.douglas

4. Enter your class name; for example, DisplayNames 

5. Click the box for public static void main and then click the Finish button.

[image: ]
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RDz creates a Java programming template as shown below.




The Program--copy the following Java Program into the DisplayNames Java program 

The package statement should be in your Java editor—my specific package is
package com.douglas;

Enter the following import statements--between the package name and the class--to import the Java classes needed for this application

import java.sql.Connection;
import java.sql.DriverManager;
import java.sql.ResultSet;
import java.sql.ResultSetMetaData;
import java.sql.SQLException;
import java.sql.Statement;

The class and main subroutine headers are already created in the Java Editor.  Thus, do not copy and paste them.
----------------------------------------------------
public class DisplayNames {

	/**
	 * @param args
	 */
	public static void main(String[] args) {

Copy the following code into the main program stub—note some comments that show the DB2 9.1 table structure 

		
System.out.println("<<< Entering DisplayNames >>>");
		if (args.length != 3) {
			System.out.println("required: location_name<userid<password>");
			System.exit(0);
		}
		try {
			Class.forName("com.ibm.db2.jcc.DB2Driver").newInstance();

			String url = "jdbc:db2://stplex4a.svl.ibm.com:8028/" + args[0];

			Connection connection = DriverManager.getConnection(url, 
                                                   args[1], args[2]);

			showPeople(connection);
			connection.close();
		} catch (SQLException ex) {
			System.out.println("\n***SQLExecption caught***\n");
			while (ex != null) {
				System.out.println("SQLState: " + ex.getSQLState());
				System.out.println("MEssage: " + ex.getMessage());
				System.out.println("Vendor: " + ex.getErrorCode());
				ex = ex.getNextException();
			}
			System.out.println("====================================");
		} catch (java.lang.Exception langEx) {
			System.out.println("\n***java.lang.Execption caught***\n");
			langEx.printStackTrace();
		}

	}

	/**
	 * showPeople method
	 * 
	 * CREATE TABLE FRIENDZ (
	 *	FNAME CHAR(10) NOT NULL,
	 *	LNAME CHAR(10) NOT NULL,
	 *	PHONE CHAR(10) NOT NULL,
	 *	EMAIL CHAR(30) NOT NULL
	 *  )
	 * AUDIT NONE
	 * DATA CAPTURE NONE 
	 * CCSID EBCDIC;
	 * 
	 **/

	protected static void showPeople(Connection connection) throws SQLException {

		System.out.println("<<< showPeople method >>> ");

		Statement stmt = connection.createStatement();

		String sql = "SELECT LNAME, FNAME FROM DOUGLAS.FRIENDZ " +  
                                            "ORDER BY LNAME ";

		boolean hasResultSet = stmt.execute(sql);

		if (hasResultSet) {
			showResultSet(stmt);
		} else {
			System.out.println("There was no result set to display.");
		}

	}

	/**
	 * Prints a result set
	 **/

	protected static void showResultSet(Statement stat) throws SQLException {

		System.out.println("<<< showResultSet method >>> ");

		ResultSet result = stat.getResultSet();
		ResultSetMetaData metaData = result.getMetaData();
		int columnCount = metaData.getColumnCount();

		for (int i = 1; i <= columnCount; i++) {
			if (i > 1) {
				System.out.print(", ");
			}
			System.out.print(metaData.getColumnLabel(i));
		}
		System.out.println();
		System.out.println("============================");

		while (result.next()) {
			for (int col = 1; col <= columnCount; col++) {
				if (col == 1) {
					System.out.print(result.getString(col) + ", ");
				} else /* col > 1 */{
					System.out.print(result.getString(col) + " ");
				}

			}
			System.out.println();
		}

		result.close();


Notes:  

· Two closing} characters are created with the Java template and thus are not shown at the end of this program.  Otherwise, you will have two extra ones in your code and thus an error.

· There are two highlighted places in your code; indications of required changes
**The JDBC string should be as shown below for our z10 system**
"jdbc:db2://130.184.26.148:446/" 

· Also, change the DB2 9.1 table qualifier to be your account  

· Save your Java program by clicking the disk icon 

· In Java perspective, an Outline window is created to assist in program development.  As shown below, clicking on an entry in the Outline window (DisplayNames in this example) will move to that location in the Java code.
[image: ]
Setup a Run Configuration

[image: ]To create a run configuration, click Run from the main menu and then click the Run option.  Select Java application and then click the OK button.



 Click Run from the main menu and select Run Configurations to open the following Run Configuration dialog with the Main tab as the default tab.  Browse for the Project: and Main class:  names.  This example uses JDBCJava and com.douglas.DisplayNames.   
[image: ]

Click the Arguments tab—this is where you will provide database information.

Note the parameters passed to the main method which are for this example
· Database name --ZUAF
· AcctID-- douglas
· Password—yourpassword

 (
Yours should be:
ZUAF 
uoasxxx
 
yourpass
) [image: ]

Click the Classpath tab.  The Classpath is very important and must contain the location of the DB2 driver along with the License Jar for DB2/z.  Under User Entries, click JDBCJava and then click the Add External Jars… button as shown below.  Browse and select each of the entries shown with the red arrows.

[image: ]

The classpaths for the remote terminal Server are the same as those indicated above—these files must be on your local machine to make this app run. . .  they are probably not on your laptop or in most labs. . . 
Click the Apply button at the bottom of the Dialog window.
Run the application within RDz 
Click the Run button; this will establish the environment defined by the Run Configuration.  The output in the Console window will be similar to below—depending on the data in your database.  

 [image: ]

If you have an error in your program, there are several ways to rerun the program.  One way is to right-click on the program in the Outline tab; Run As  Run Configurations  Run (this run will from the Classpaths tab shown above).  The most intuitive way is to click the dropdown on the green go button; select Rus As and then Java Application as shown below.

[image: ]

Sam M. Walton College of Business – Enterprise Systems	Page 9

image2.png
New Window
ey Edtor

Foong

Show iew FFe2i0s Projects

Custamize Perspective.

Save Perspective As.
Reset Perspective.
Close Perspective
Close Al Perspectives

Navigation »

Preferences





image3.png
© Java - 16M Rational Developer for System 2
Flo Edt Navigate Search Praject Run Window Help

| W= I$-0-@-| 5|8
[% packa 53 _fg Herar| & cicsp| = 0|

5% v

& SCLMConfigProject




image4.png
Select a wizard

Create a Java project

igards:

oo ke et

T Dt oo ot
0 Dt DevlopmentPojet

5 2ava Proec Fom Exitng A uidie
5 P proect

& General

&= coBoL

& o

& Data

= Eclipse Modeling Framework.

=B

& Graphical Modeling Framework

& Java

I~ show Al wizards





image5.png
 New Java Project [_[CIx]
Create a Java Project

—d
Creste a Java project inthe workspace of in an externa location. /

Project name: | IDBCIaval

- Contents
& Create new project in workspace.

" Create project from existing source.

Orectory: [CUsers oo By sonasepworkopaceioBCIova | _Erase.

®e
& Use defak RE (Currently k) Confiae REs
© Use o project speifi RE: iac 2

" Use an execution environment JRE: [Jaaoe 1 & o

[“Projectlayaut

" Use projectFolder as rootfor sources and dlass fies

 Create separate folders for sources and class les Confioure defaul,




image6.png
@ Java - IBM Rational Developer for System z

Fle Edt Souce Refoctr Novgate Serch Profct Run
Jrs- I$-0-a-|s5 |86

BRaicseraio F T Herardy] & CICplx o

2 src
= IRE System Library (i3]
& SCLMConfigPraject




image7.png
) New Java Package

I[=1 B3
Java Package

Crestes folders correspondingto packages.

Source folders [ 0BCIavarrc

==

Name:

[com-uoasosel




image8.png
0 New Java Package

[_[CIx]
Java Package

Crestes folders correspondingto packages.

Source folders [ 0BCIavarrc

==

Name:

[eom dovgo]




image9.png
R —— i)

-
B oBCIava

B s

®
= IRE System Lbrary (i3]
&2 SCMConfigProject





image10.png
Java Class

Source folder TDECIavalsre Browse,

Package: [comdouges _Browse... |
T~ Enclosing type: 7 Erowse.

Name: msmawames

Modfiers: Gopublc  Codefaukt O prvae  C proterted
I~ abstract [~ final [~ sisiic

Supercass: [valngobect | Browse.
Interfaces: add,

T

Whichmethod stubs woukd you heto reate?
2 pubic statc vord mainStrngl] args)
/' I Constructors from superclass
7 Inherked bstract methods

0 you want to add comments? (Configure templates and defaul value here)
I~ Generate comments

G =




image11.png
Fle Edit Source Refactor Navigate Search Project Run Window Help
i-lels-0-a-|s|s8s6- o958 -
£ pac 22\ fg He | ac| = O

0%~ ackage com.douglas;
==
= oacamve

G e public class DisplayNemes {

= com.douglas

[5) Dipaytiames.ava s
= JRE System Lbrary [i3] V@xmam arge

&2 SCMConfigProject
©  public static veid main(String[] args) (

// TODO Auto-generated method stub




image12.png
(1) Diplaytiames.java 23

package com.douglas;

“import java.sgl.Connection;
import java.sql.DriverNanager;
import java.sql.ResultSet;
import java.sql.ResultSethietabata;
import java.sql.SQLException;

import Java.sql.ﬁ\:a\:emen\::/

public

B
* Gparam args
1%

B R W e

#  com.douglas.

import declarations
= java.sal. Comection

“~ javasal DriverManager
java.sal ResutSet

java.sal ResultSettietabeta
Java.sal. 5QUExcepton
java.sal. Statement
Displyiiames

© ° main(Stringl})

©® showPeople(Connection)

© % showResultSet(Statement)





image13.png
©Run As [_[o[x]

Select a way ta run Displayiames. javai

B runon Server

a Application

- Description
Runs alocal Java application

ol





image14.png
 Run Configurations

Create. manage. and run configurations

EEEIEES

ane: [Dipeytianes

© main e

[-Project:

vguments | =, JRE | Classpath| & Source | I Envronment | ) Common| |

T3, compied Application

@ Eclipse Appiication

9 Ecipse Data Tools
Generc Server

[oecieva o

Generc Server(Extemn:

B Host C/C++ Appicatio

83 Host Java Appication
Java dpplct

Javs Appcation

Oiplaiames

Y JET Transfomation

Ju e

3% Jni Plug-in Test

% os6iFramenork

com.Gouges Deployiames search

(o ||
(=

T~ Include system libraries when searching for a main class

I~ Include inherited mains when searching for @ main class

I Stopin main





image15.png
© Run Configurat

Create. manage. and run configurations

Run a Java appication

EEEIEER

fvpe fiter text

3, compied Appicati
© Edpse Appication
9 Ecipse Data Tools
Generc Server
Generc Srver(ex
5 Host C/C+-+ Appic)
83 ost Java Appcat
5 Java dprlet
551 Jova Appication
5] Displayames

Nane: [Dipeytames

(® ran

rquments

= RE | %, Classpath £ Source| %2

Program arguments:
ZUAF acctid password|

|

|
Varabes
[





image16.png
{9 Run Configurations.

Create, manage, and run configurations

EEEIEER
fvpe fiter text

Nane: [Dipeytames

rquments (=, JRE [ Classpath . T source | 7 Environment | (] Common |

. (@ ran i
=, conpe st | [0
@ Eclipse Application

9 Edlipse Data Tools =% Bootstrap Entries w
Generic Server B JRE System Library [jdk]
(Generic Server(Exter B ‘ﬁev Entries. Down
it e Applcat 5 s eense_ce - CproramFis o8 EMSQULIE v —
8 Host Java Applicatior [ db2jcc jar - C:\Program Files (x86){IBM|SQLLIBYjava),
adprofect.

3] Java Applet

o e == P
imanes [ ]
e JET Transformation Add External JARs,
Ju Unit " a
T At e e T
B osciFramework =

Restore Defaul Entries





image17.png
(2. roblems [ @ 3avadoc ([} peclration [ B console 3 ® % |
<terminated:» DisplayNames [Java Application] C:{Program Files (x86){IBMISDP\jdkibinijavaw.exe (May 29, 2009 1:23:15 AM)
Daviz  , Christine

Douglas , David

England | Larry

Jones . George




image18.png
BM Rational Developer for Sy
lsvigate Search Project Run Window Help

| wi e [$-0-Q-|s|Ba6-|®s-|¢ |1
lap 53 \2 = O] 2]t DsplayNames I 1/

Flo Edt Souce Refar

e - .ﬁlRunanSeWe* Aletshiftrs, R
| RunConfiguratons, ava Appcati ‘
S maome = 2.3ava Application. A+, 3

st Organize Favaries.




image1.png
© 0pen Perspective [_[o[x]

Facm

[Eacvs Repostory Exploring

(GDatabase Debug

(3 Database Development

F5Debug

i\Fau\t Analyzer Perspective.
;mma sromsing

2 Java EE

122 Jva Type Herarchy

& savasait

4p=Plug-in Development

ThRemote System Exprer

[Resource

fysam

1o synevarizng

& wed

ezjos Projects (defaut)

T~ show all




image19.png
@ UNIVERSITY OF

— ARKANSAS

LUV SAM M. WALTON

|
COLLEGE OF BUSINESS





